Ресурс не считывает базу данных



  • Бас считает что ресурс база пуст. Об этом сообщает в логе и на вкладке отчета по ресурсам красной цифрой 0.
    База конечно же далеко не пустая.
    Лечится 1-2 перезапусками.
    Происходит спонтанно, наблюдения не дали каких-то зацепок. Проявляется на любых скриптах во время работы.
    Режимы: запуск и вроде как запись. Но тут под вопросом режим записи т.к. замечаю в последнее время именно в запуске.

    Проявляется на всех недавних версиях бас (20.5.0 включительно).

    Не заметил особой разницы между сильно нагруженными базами и только созданными. Хотя может сильно нагруженные чаще встречают этот баг...
    0_1508763374715_upload-f73a6b68-ddab-48b5-a760-87f9f52ee3dd

    Ошибка проявляется на всех пк. На серверах, на моем пк и недавно на пк клиента.
    0_1508763262295_upload-3a79d393-c8c9-4e98-ae38-cf49f77b1f1f
    0_1508763283499_upload-828f2707-92a3-4e6e-aafe-2b53068f13ea

    Как вызвать этот баг не знаю. Я чаще сталкивался с этим багом когда на сервере работает скрипт который перезапускается раз 10 в сутки. И несколько раз в неделю я замечаю скрипт повисший в ожидании ресурса базы.

    Еще один раз был случай - пропали записи в одной из таблиц, но тут точно не известно почему так случилось поскольку у меня есть функций удаления старых записей по истечении времени, возможно что-то не так я рассчитал)



  • тоже бывало, всегда при старте, при перезапуске все работало. Тоже спонтанно, с разными базами, в разных скриптах, на разных пк