Скрипт не запускается на сервере.



  • Добрый день! Запускаю скрипт на компе - всё работает. Запускал на сервере - закрывается с ошибкой. Windows Server 2012 R1. На серваке есть net framework 4.7, visual c++, directx.
    Вот лог:
    Имя события проблемы: APPCRASH
    Имя приложения: FastExecuteScript.exe
    Версия приложения: 0.0.0.0
    Отметка времени приложения: 5a546545
    Имя модуля с ошибкой: Qt5Script.dll
    Версия модуля с ошибкой: 5.6.0.0
    Отметка времени модуля с ошибкой: 56d91442
    Код исключения: c00000fd
    Смещение исключения: 000000000008d2a5
    Версия ОС: 6.3.9600.2.0.0.272.7
    Код языка: 1049
    Дополнительные сведения 1: 5f01
    Дополнительные сведения 2: 5f01f3ad3b49535549997e84cbe17ea1
    Дополнительные сведения 3: 7cc9
    Дополнительные сведения 4: 7cc97be50f3a5e1f10647bb470b500db



  • У многих БАС запускается на серверах спокойно. Я же пока спасаюсь только связкой linux server + lxde + virtualbox. В виртуалке поднимаю домашнюю семёрку. Благо, цены на линуксовые серваки есть совсем бросовые, так что объём памяти в виртуалке обходится зачастую так же как и виндовый сервер. А вот количество ядер выделить большое не удаётся, так что по процессору отстаю от сервака на винде.



  • @Pragmatik, а на других серверах такая же ситуация. Что за хостинг? На других версиях ос?



  • @Antonio
    http://zomro.com/vds.html
    Пробовал так же предложение от https://www.king-servers.com/
    У них на серваки запилена windows 7, видимо они её подгоняли под серверное железо и при установке всех необходимых библиотек и фреймворков товарищ BAS всё равно не робить.
    Может подскажете варианты провайдеров, у которых сервак точно тянет БАС?



  • @Pragmatik, у меня на Зомро все ок работало.



  • @Antonio
    Странно, у меня именно на нём эта ошибка появилась. И скрипты разные пробовал.



  • @Pragmatik, может быть нужно антивирус отключить. Или попробуй не скомпилированный скрипт запустить, а в основной программе. Но у меня там вообще проблем не было подобных. Дополнительно на винду не ставил ничего. Только отключал.



  • @Antonio
    Отлично, помогло. Делал на king-servers. Поставил на сервере БАС, скомпиллировал в нём скрипт - всё работает отлично!) Так что если у кого-то проблемы с запуском, компиллируйте скрипт не на компе, а на серваке.