Поток завершился с сообщением "Search image timeout"



  • Ошибка "Поток завершился с сообщением "Search image timeout"".Работает много потоков,понимаю,что при работе такого количества свойственны ошибки.Но я не могу понять природу сего явления.Истекло время поиска изображения,т.е он не может начать работу с поиском картинки?ведь если он её не найдет то должно быть значение false в переменной



  • @delarofficial, природа такова, что это глюк БАСа. У меня бывают ошибки таймаута при выполнении действия "If".
    Т.е. это не то, что БАС искал изображение слишком долго, а то, что он пытался выполнить экшен (любой), но не смог и вышел по таймауту.



  • Эх,печальная штука:с



  • @delarofficial, единственный 100% вариант тут - это абсолютно каждое действие оборачивать в игнор ошибок и делать обработку ошибок. Если не слишком большой скрипт, то можно провернуть. Если большой, то нагрузку регулировать - меньше потоков, мощнее комп.



  • @Antonio Скрипт огромный(,но по сути проблема только при старте,так что попробую закинуть в игнор.Сервер сам по себе мощный,так бы на http запросы перешел,но проект не позволяет



  • @delarofficial, если при старте, то делай задержку старта потоков в зависимости от номера потока. Тема есть на форуме.



  • @Antonio Задержка стоит,всё равно не выдерживает,попробую и её ещё увеличить.Спасибо)



  • @delarofficial проще уменьшить кодичество потоков. Понимаете, логика такова. В 20 потоков все хорошо, в 30 сыпятся ошибки.
    20 потоков дают 100 полезных результатов на едигицу времени, 30 - 75.

    Если вы предприняли все действия по оатимизации скрипта (задержки, минимально количество действий, пропуск кадров), то имеет смысл просто снизить кодичество потоков до комфортного для машины



  • @DrPrime, например, в моем случае не так просто все. 95% времени скрипт работает как надо, но бывает, что у него замыкает в мозгу и летят подобные непредсказуемые ошибки пачками. Но все равно так выгоднее.



  • @Antonio У меня похожая беда, даже обработка ошибок не спасает. Иногда бывает, что два раза подряд таймут при загрузке поймает и просто колом встает. Сам БАС работает, а скрипт стоит :) Админ утверждает, что такого быть не может, но факт, что есть, правда очень редко :(



  • @Denis_krsk, вот такого не видел ни разу. А в логе что пишет в этот момент? Сейчас же все ожидания там отображаются.



  • @Antonio Прикол в том, что ничего :) Более того все ошибки в лог выводил. Выходило два таймаута, а потом ничего и в снифере ничего. Справедливости ради скажу, что не так часто такой баг ловил, сейчас не использую действие дождаться полной загрузки страницы, вроде пока норма, может в с ним было связано, а может и нет.А еще ловил глюк с закрытием вкладки. Ставил ее в блок игнора и получалось, что она она как-то не до конца закрывалась :) Судя по снифиру новые страницы грузились, но на экране старая оставалсь и скрипт не мог само собой найти нужный селектор :) Теперь ява кодом закрываю только



  • у меня такая ошибка обычно бывает когда пропадает интернет, или меняется разметка целевой страницы