Как запустить Мультилогин?



  • Судя по инфе из одного видео автора для использования мультилогина (браузера MLAMimic) нужно просто в начале скрипта добавить функцию "мультилогин" с параметром MLAMimic. Далее я запускаю в режиме "запуска" и получаю ошибку:
    "Удачно(0)
    Неудач(1)
    Сообщения:
    1 - Закончен с сообщением: File C:\Users\admin/.multiloginapp.com/app.properties not exists
    Время работы : 00:00
    Последнее сообщение : Закончен с сообщением: File C:\Users\admin/.multiloginapp.com/app.properties not exists"
    Что я делаю не так?
    Простейший скрипт:
    alt text
    0_1525975550268_тест.xml



  • @botovod
    мултилоге установлен?



  • @ruzne у меня версия 20.8.7, дополнительно ничего не устанавливал. Но кнопка "Multilogin" в интерфейсе есть. Он по умолчанию должен быть вроде.


  • administrators

    @botovod Мультилогин это отдельная программа. Качаешь тут.
    Выглядит вот так:
    0_1526018966018_upload-90dc1205-0fa0-406a-b965-eacb11f75bdf



  • @Fox не запускается последняя версия мультилогин (2.1.1) через БАС. Вы дает ошибку: "Неудач(1)
    Сообщения:
    1 - Закончен с сообщением: Failed to start MLA for a long time

    Время работы : 00:31

    Последнее сообщение : Закончен с сообщением: Failed to start MLA for a long time"
    И это при том что я поменял название папки в Program Files c Multilogin на Multiloginapp и исполняемый файл, иначе бас вообще его не находит.


  • administrators

    @botovod Можешь просто запустить Mla и не закрывать его.



  • @Fox Точнее мультилогин запускается, но при этом не запускается браузер мультилогина (mimic). А если оставляю окно мультилогина открытым с открытым браузером mimic 9запущенным через мультилогин) и делаю запуск скрипта в БАС, то запускается еще одна копия мультилогин и в БАСе вылетает ошибка: "Удачно(0)

    Неудач(1)
    Сообщения:
    1 - Закончен с сообщением: Failed to start MLA for a long time

    Время работы : 00:31

    Последнее сообщение : Закончен с сообщением: Failed to start MLA for a long time"
    Вот скрипт: 0_1526075750400_тест отпечатка.xml



  • Тоже выдает ошибку такого плана: Закончен с сообщением: C:/Program Files (x86)/Multiloginapp/multiloginapp.exe doesn't exist, is MLA installed? Хотя сам МЛА в этот момент был запущен...



  • Может есть тогда у кого Multilogin v1.4.1? Залейте на обменник какой нибудь, а то на офф. сайте нет старых версий.


  • administrators

    @botovod

    Может есть тогда у кого Multilogin v1.4.1? Залейте на обменник какой нибудь, а то на офф. сайте нет старых версий.

    Прямо в самом BAS, в описании экшена Использовать Multilogin есть ссылка:
    0_1526126103849_на форум 5.png

    Выкладываю тут, а то вдруг и с этим проблемы будут..



  • @Fox Все равно ошибка вываливается " Закончен с сообщением: Failed to start MLA for a long time".
    Зеленую точку поставил напротив значка браузера в мультилогине. При запуске скрипта запускается прога мультилогин (с профилями) и все, дальше ничего не происходит. Если нажимаю значек браузера (ктати там значек файрфокса почему-то появляется, хотя открывается хром, а в видео автора другой значек) - открывается браузер, но в нем не воспроизводится мой алгоритм.
    Ну как его заставить а?
    Вот скрипт: 0_1526238272572_новый.xml



  • Кажется понял в чем проблема: автор в видео при создании профиля выбирал браузер Хром, а я сейчас выбрать его не могу в бесплатной версии. Видимо эта функция в БАСе завязана именно на Хром. Получается теперь что этот функционал теперь платный?


  • administrators

    @botovod Нужно создать профиль. Если хотите онлайн профиль, то создавайте его в приложении mla
    0_1526239972850_upload-57f1c02b-615a-4a4d-b8f6-f185e0bd4de3

    если пойдёт и оффлайн профиль, то создайте его одноимённым экшеном.
    Вот тестовый скрипт.



  • @Fox said in Как запустить Мультилогин?:

    Если хотите онлайн профиль, то создавайте его в приложении mla

    Да хочу онлайн профиль. Создал его в приложении MLA. Затем в БАСе после действия "использовать multilogin MLAMimic" я создаю действие "переключится на онлайн профиль", а в качестве id указываю Session ID. Запускаю всю эту конструкцию и... ничего не получается, браузер открывается, но действия в нем не выполняются и таже ошибка в басе: "Failed to start MLA for a long time".


  • administrators

    @botovod Откройте и не закрывайте mla. Запустите этот скрипт. Что пишет в логе? Или тоже с ошибкой вылетает?

    Получается теперь что этот функционал теперь платный?

    Не паниковать! Ни какого апдейта ещё не было.



  • @Fox открыл МЛА. Запустил ваш скрипт в BAS в режиме "запуск". После запуска открылась еще одна копия программы МЛА! Спустя несколько секунд в логе BAS появилось это:
    "[14:20:06] Поток №1 : Поток завершился с сообщением "Failed to start MLA for a long time"
    [14:20:06] Скрипт завершен корректно"
    Версия МЛА 1.4.10.296-windows-x86_32
    BAS утанавливал не в директорию по умолчанию, а в Program Files.


  • administrators

    @botovod Попробуйте запуск оффлайн профиля. Вот тестовый скрипт.
    Порядок запуска такой же, запустить программу mla (не профили браузера, а просто саму программу), и запустить тестовый скрипт в режиме запуска



  • Такие же проблемы. На версии МЛА 1.4.10 "Failed to start MLA for a long time" . На последней вресии просто не видит, что МЛА установлен. Хотя директория по умолчанию.



  • @Fox Точно та же ошибка: Failed to start MLA for a long time.


  • administrators

    Сейчас могут быть некоторые проблемы, но мы работаем над этим. Сейчас я быстро обновлю движок хрома и добью интеграцию.