Плюшки для премиум



  • Считаю что галочка "отключить автообновление" и "не уведомлять о новых версиях" должна быть доступна всем. Речь о работоспособности софта и банальном неудобстве когда нужно скипать мелкий фикс ради того чтобы не переставлять программу.

    0_1532663532973_2018-07-27_064631.jpg



  • Добавлю сюда.
    Мне пока не горит, но возможно кому то пригодится.
    Не лучше бы было вместо айпи разработчика в новом интрефейсе указывать логин разработчика? Тем, у кого динамик айпи, было бы удобно



  • А еще логин с паролем не сохраняется, при каждом перезапуске BAS просит авторизоваться заново, для возможности работы с html-интерфейсом


  • administrators

    @drprime

    1. Авто обновление.
    2. Версии.

    Пока рекомендуется делать отдельную версию, как вы и описали. Например, Script и ScriptDevelopment

    1. Обновление скриптов из самого BAS.

    Загрузка скрипта на сервер уже реализована в новой версии, также реализовано создание приватного скрипта из интерфейса БАС.

    1. Менять версию скрипта в BAS из какого либо меню. На данный момент есть 3 варианта:

    Это тоже реализовано, есть возможность менять версию не пересоздавая архив. Вообще окно компиляции переработано. https://youtu.be/99g8MK_z224

    1. API для выдачи лицензий. Позволяет делать для своих скриптов автоматическую оплату и выдачу скриптов пользователям, а так же их продление, например сразу с лендинга.

    Это тоже реализовано, но немного другим способом. Вы можете сгенерировать список логинов и паролей и залить его на сервер, а потом этот же список продавать у себя на сайте. Лицензии буду генерироваться не в момент создания, а при первом использовании.

    1. Возможно мало кому будет полезно, но, в дополнению к версиям, иметь возможность указать еще период, когда человек может получать обновления.

    Вы можете вручную редактировать срок действия любой лицензии индивидуально для каждого пользователя. Так что это уже реализовано.



  • Когда мы сможем скачать новую версию? Кажется впечатляющим


  • administrators

    @nicog где-то 8 ноября планирую новый релиз



  • @support не хочу быть навязчивым, прошу обратить внимание на эту тему: https://community.bablosoft.com/topic/5654/добавить-поддержку-socks-4-прокси
    Все-равно обновление будете выпускать)



  • @support

    @support said in Плюшки для премиум:

    Пока рекомендуется делать отдельную версию, как вы и описали. Например, Script и ScriptDevelopment

    Ну так и делаю, но это жутко неудобно, куча версий, куча скриптов, контроль пользователей, одним эту, другим эту, куча обращений, куча лишних движений.

    @support said in Плюшки для премиум:

    Это тоже реализовано, но немного другим способом. Вы можете сгенерировать список логинов и паролей и залить его на сервер, а потом этот же список продавать у себя на сайте. Лицензии буду генерироваться не в момент создания, а при первом использовании.

    Ну это же абсолютно не то.

    • Использовать пользовательские лог:пасс нельзя
    • Продление не реализовать никак
    • Нужно делать разные пачки на разные сроки

  • administrators

    @drprime Безусловно, АПИ для магазина будет реализовано, но в следующей версии будут только пункты 3 и 4
    Вместо функционала для беты, я бы лучше реализовал систему для автоматического тестирования.


  • administrators

    В этой теме я обещал выпустить новую версию 8 ноября, но я вынужден отложить релиз до 12 ноября, для этого есть 2 причины:

    1. Я ожидаю проверку данных для получения сертификата, это позволит убрать предупреждение при запуске приложения, также антивирусы относятся к приложениям с сертификатом более лояльно.
    2. Осталось еще несколько задач связанных с отпечатками, которые я не успел сделать(аудио отпечаток, смена часового пояса на уровне браузера).

    Пока вот скриншот новых параметров из действия прокси:

    alt text



  • Извините, что беспокою вас, но это обновление только по-русски или вы планируете перевести его на английский?



  • @support еще тут писали
    https://community.bablosoft.com/topic/5429/what-version-of-chrome-is-being-used/2
    есть в планах апнуть версию ?