кодировка "Ввод текста неправильная"



  • Всем доброго времени суток. Есть необходимость вводить смайлы. если делать все в обычном браузере то все хорошо. Т.е копирую с файл смайл вставляю его в браузере и он отправляется нормальным. а вот через скрипт, берет с того же файла и тот же смайл, но смайл после отправки не распознается. Пробовал копировать с файла и вставлять напрямую в "ввод текста" и отправить. так же не распознался смайл. Значит итог... некорректаная кодировка самого БАС



  • @smurfik какой сайт?



  • @smurfik мне кажется нужно сохранить файл со смайликами в кодировке utf-8



  • @DrPrime Insta. но это не имеет значения. так на всех сайтах. некоторые смайлы нормально работают, а некоторые бас просто не воспринимает.



  • @Стас нет, не в этом дело. не воспринимает даже если я вручную вставляю смайл в "ввод текста". сначала тоже думал проблема в кодировке, но после вышеописанного понял, что не в этом дело



  • вообщем чтобы сразу все понимали о чем я. заходим через браузер в акк инсты. редактируем профиль. вставляем в описание текст и смайлы. в обычном браузере все нормально. если это все сделать через бас, то смайлы будут заменены на квадратики.НО не все. есть смайлы которые нормально сохраняются.



  • вот что удалось нарыть. http://getemoji.com/ откройте сайт в хроме и в мазиле. в хроме не показывает процентов 90 смайликов, а те что есть показывает чернобелыми... вот как раз они в бас и работают. а в мазиле показывает все смайлы, но в бас они не работают. т.е все проблема в том что используется хром в бас



  • @smurfik а добавленные через БАС смайлы видны через приложение инсты?



  • @DrPrime нет, вместо смайла в квадрате знак вопроса... выше я скинул сайт и написал в чем причина. скорее всего именно в том что используются хром. он не распознает все смайлы



  • @smurfik
    Прописывайте смайлы Emoji кодом, например:

    😊 = 😊

    Или ещё один способ смотрите здесь.



  • @wodopad по поводу кодов я знаю, но в моем случае этот вариант не подходит. второй вариант так же не подходит. нужно именно чтобы вставляло сразу смайл, и корректно работало как ив обычном браузере


  • administrators

    @smurfik В ближайшее время разберусь. Можете прикрепить файл со смайлами?



  • @support я выше писал сайт со смайлами. в обычном браузере просто 2 раза нажимаешь, он выделяется, потом ctrl +c и вставить в любое поле ена любом сайте.


  • administrators

    @smurfik Пока такой костыль. Вводить текст нужно без эмуляции, потом ввести пробел и <BACK> c эмуляцией.
    Вот реализация.

    0_1481626395840_instasmiles.xml



  • @support ok. спасибо посмотрю.



  • @support Спасибо. Метод в Инстаграм работает.

    А вот к FB не как не могу применить. Делаю репост, добавляя сообщение со смайликами. Если отключить эмуляцию, текст не добавляется, а с эмуляцией вместо смайлов квадратики.


  • administrators

    @solt На фб работает такой же метод как в инстаграме.

    0_1485621959271_SmiliesFb.png

    Вы точно сделали как написано тут

    Вводить текст нужно без эмуляции, потом ввести пробел и <BACK> c эмуляцией.

    Если ничего не будет получаться прикрепите проект, или скопируйте действия, которыми вводите текст и вставьте сюда.



  • @support said in кодировка "Ввод текста неправильная":

    Вводить текст нужно без эмуляции, потом ввести пробел и <BACK> c эмуляцией.

    0_1485670631009_test.xml

    Пример скрипта.

    С эмуляцией текст вводится, а при отключении, действие не производится.


  • administrators

    @solt На этой форме нет элемента textarea, поэтому ввод без эмуляции не работает. Единственный вариант тут - использовать буфер обмена. Сохранить туда значение через <CONTROL>C, а потом вставить через <CONTROL>V



  • @support said in кодировка "Ввод текста неправильная":

    <CONTROL>C, а потом вставить через <CONTROL>V

    Подскажите пожалуйста, как можно занести текст по средствам BAS не используя "экшин Ввод текста" и <CONTROL>V в буфер обмена.

    Попытался через "экшин Запустить процесс" с параметрами:

    • clip < "D:\Папка\BAS\Текст.txt" - не работает, в буфер не чего не заносится
    • @echo текст| Clip - сработал, но проблема с кодировкой (нормально отображается только латиница)

    Возможны другие варианты, скопировать текст в буфер обмена?

    Например через:

    • переменную
    • файл
    • список
    • ресурс