Постоянные баги с тем, с чем раньше проблем не было!



  • Был рабочий скрипт, который работал безупречно. Решил добавить ещё одну версию модема ( для получение нового ип модем ребутаеться. ) И тут понеслось, первый звоночком стал баг работы ресурсов. В списке были разные версии модемов и от того какой выбран модем такая функция и запускалась. И теперь вместо того что бы вызывать соответствующую функцию как раньше, оно постоянно вызывает одну и ту же ( условно назовём её 153 ) вне зависимости что ты выбрал. Повторяюсь раньше этот механизм работал безупречно. Но это только половина беды. Дальше проблемы появились там, где их никогда не было.... массивы.
    Вот как он составлен и раньше работал также безупречно: https://imgur.com/a/dsFvX36. Этот алго изменений не претерпевал уже как более 6-ти месяцев. А теперь постоянно эта ошибка.

    Ещё одной бедой стал вайт лист. Есть тхт документ , в котором указанны сайты, которые не должны парситься. Но после очередного моего обновления ( по добавлению новой модели модема ), эта функция также перестала адекватно работать. И пофиг на вайт лист, парсит всех без разбору.
    Алгоритм не претерпевал изменения в этом обновлении, и раньше также работал безупречно.

    То бишь 2 проблемы: это ресурсы и массивы.
    В режиме откладки работает всё отлично, в многпоточке - все эти баги.
    Если кто то думает что надо добавить задержку, так она есть там. Дело не в ней.
    И вот что я кстати обнаружил странного: https://imgur.com/a/A4Ge6KZ
    Можно заметить иконку "123" в место рисунка "тхт"



  • @xxAsa_Renxx, посмотрите код действия (которое выдает "Left side of assignment is not a reference"), возможно там есть ошибка. Можете попробовать просто пересоздать данное действие.


Log in to reply