Issues with proxy on latest version of BAS and Fingerprint Manager



  • Hi just want to say I love this project of yours! I subscribe to key for fingerprint even though i don't need just to support you 😊

    Anyways I updated yesterday to latest version of BAS and FingerprintManager but now I have issues with a proxy provider with HTTP method. I know this provider uses gzip in all requests as I have had issues in the past with this provider and curl (solved it by removing encoding from requests), so maybe that is the reason this time?
    Tried 2 other proxies, they work so it looks to be exclusive to this proxy provider. I have confirmed this provider still works by using Chromium, Firefox and earlier version of CEF so it looks to be only this latest version since it stopped working when I updated.

    On fingerprintmanager, when I click "Check Proxy" I get a success message but when I try to start the profile I get "Proxy error". Every time.

    Possible this issue is about encoding so if you have time over please feel free to check 😊

    EDIT:
    I forgot to add, when I try the same proxy with the HTTP-client it works without issues.
    Only set proxy in browser is not working.



  • i had the same issue,

    somehow when BAS fails to validate proxy to ip.bablosoft.com it just steps through, no error thrown.
    the best is to use fiddler to view entire conversation.

    i tried to fix the issue however it seems dead end, since no docs.



  • I tried to use Burpsuite with the same settings and that made it works, so it must be of how BAS parses the request response it receives.


Log in to reply