restore saved fingerprint from saved profile



  • I have a profile that saved fingerprint, cookies and everything. When I switch to this profile fingerprint is not restoring only if I use the command "get fingerprint" and the command "apply fingerprint".

    Do you know how can I restore the fingerprint that I get with those commands the next time when I open the bot?

    Thanks



  • anyone can answer my noob question?



  • Seems I have the same issue. I use the fingerprint, then save the profile and then when I restore it the fingerprint is different (navigator.useragent is the same as normal BAS browser fingerprint)
    A solution is to save the fingerprint key to the database / file using a resource then restore it from the resource.
    Hope this helps.



  • @HELP_ME said in restore saved fingerprint from saved profile:

    Seems I have the same issue. I use the fingerprint, then save the profile and then when I restore it the fingerprint is different (navigator.useragent is the same as normal BAS browser fingerprint)
    A solution is to save the fingerprint key to the database / file using a resource then restore it from the resource.
    Hope this helps.

    Enable the "Always load fingerprint from profile folder" option in the "Create or switch to local profile" action

    0e06467c-83c2-4119-a726-055b5a6c7847-изображение.png



  • @Fox Appreciated but it's already enabled by default.

    What I discovered is that the fingerprint saves the database key at the end of it which is possibly why others had this issue before. (Unable to parse JSON string)

    But a lot of posts are in Russian and the translator doesn't do it justice... I am definitely missing stuff over there. Need a solution.

    Example of script that reproduces error:
    test.xml
    Script that I used to error: - If anyone has this issue use this template to solve it
    solve_fingerprint.xml



  • @HELP_ME said in restore saved fingerprint from saved profile:

    @Fox Appreciated but it's already enabled by default.

    What I discovered is that the fingerprint saves the database key at the end of it which is possibly why others had this issue before. (Unable to parse JSON string)

    But a lot of posts are in Russian and the translator doesn't do it justice... I am definitely missing stuff over there. Need a solution.

    Example of script that reproduces error:
    test.xml
    Script that I used to error: - If anyone has this issue use this template to solve it
    solve_fingerprint.xml

    You get data from the database, the result is "string" and "record id". You don't separate them, so an error occurs. I added the encoding of the string in base64 for clarity

    test18.xml


Log in to reply