слетает авторизация в 22.5.1, но работает в 22.7.1



  • готовил проект админу по поводу повышенной прожорливости на ЦП в новых версиях и заметил, что в одной версии БАСа есть авторизация с профиля, в другой просит логин.

    22.5.1 просит авторизацию - (на этой версии планировался замер ресурсов ЦП и скорости работы скрипта)
    22.7.1 автоматическая авторизация с профиля работает

    в обоих случаях перед включением профиля в работу удаляются обе папки кеша.
    после выбора профиля в обоих случаях задается юзер-агент и язык.
    скрипт то один и тот же.

    отключение подгрузки фингерпринта (на всякий случай, при реге вряд ли задавался) из профиля не сбрасывает авторизацию в последней версии и не чинит ее в старой. тоже самое с установкой пустой прокси (все опции в true)

    как лечить, чтобы по профилю в обоих версиях срабатывала авторизация?

    обратной совместимости похоже что нет.



  • @oleg4ever в каких то версиях были изменения в хранении кук.
    и в этих версиях хранилища куки не совместимы с др.

    можно получить эти куки и самому сохранить где-то, что бы потом прописывать в браузере.

    хотя могу ошибаться. в течении месяца вышло очень много версий



  • Версия 22.6.* была полностью посвящена апу на новую версию движка. В ней были изменения сохранения кук. Поэтому да, к сожалению, куки из профиля 22.5 и 22.7 несовместимы.


Log in to reply