Поток зависает



  • Начал делать небольшого бота для приложения в контакте. Работы было минут на 5-10, но в итоге все растянулось около двух часов, и не получилось решить проблему. BAS зависает при запуске приложения, и никакие танцы с бубном не помогли. Приложение запустилось единственный раз - когда я в первый раз прописывал действия в шаблоне. Далее просто перестало работать. Даже попробовал создать новый проект и сделать все, как в самом начале, но все равно то же самое. Возможно, все-таки дело в разрешении, и если оно при создании браузера рандомное - то в первый раз повезло и оно "подошло".
    Вот проект:
    0_1488265597071_agario.xml



  • @blackhacker Не зависает, а ждет, пока на странице не появится элемент с заданным селектором и выдает сообщение об ошибке после того, как элемент на странице не обнаруживается.

    [13:40:48] Поток №1 : Не удалось дождаться элемента >CSS> #app_4964107_container > iframe >FRAME> >CSS> #lobby2 > :nth-child(1) > :nth-child(1) > :nth-child(4) > :nth-child(1)

    В данном случае БАС ведет себя абсолютно корректно. Правьте скрипт.



  • @support У меня в логе нет ошибок, да и клик по элементу происходит. Значит, элемент все-таки есть



  • @blackhacker В чем проявляется зависание?



  • @support В окне записи никакие элементы не реагируют на мышь. Только кнопки окна (Свернуть, Развернуть, Закрыть). Но основное приложение BAS работает.



  • @blackhacker На какой элемент вы пытаетесь нажать?



  • @support То, что пометил красным - не реагирует на наведение\нажатие мыши, синим - кнопки управления окном (работают)
    0_1488282499467_Безымянный.png
    P.S. скрипт выполнился и завис. Но если есть действия после, то они уже не выполняются.



  • @blackhacker Хм не знаю, у меня работает.

    0_1488283256936_VkGame.png



  • @support Нет, нужно нажать на кнопку "Начать игру", и должно запуститься так:
    0_1488283058383_Безымянный.png
    Но после нажатия на кнопку зависает на "Загрузка игры"

    Чтобы меня не осуждали, что отнимаю время "какой-то игрой", я создал тему не из-за игры) А для исправления бага. Бота же можно и через обычный браузер в iMacros сделать. Но если эта задача не представляет сейчас важности в улучшении BAS, то она подождет.



  • @blackhacker Так тоже работает.

    0_1488283725160_VkGame2.png



  • @blackhacker наоборот, хорошо ,что ты пишешь и показываешь где проблема. Там дело не в игре, такое может случится на любом сайте, а благодаря тебе проблему получится локализовать и устранить.



  • @blackhacker Попробуйте отключить
    --disable-gpu
    --disable-gpu-compositing

    В файле chrome_command_line.txt и прислать worker_log



  • @support Тот же самый проект работает, который скинул? Я уже всяко пробовал, разрешение разное, user-agent (думал, что для разных браузеров разная совместимость), проксировал запросы, думая, что какой-то скрипт роняет поток, или недогруженные картинки. Сейчас попробую в видео или gif записать результат работы скрипта.



  • @blackhacker Тот который вы скинули, и добавил прокликивание туториала.

    Попробуйте отключить
    --disable-gpu
    --disable-gpu-compositing
    В файле chrome_command_line.txt и прислать worker_log

    Видео - супер



  • у себя тоже запустил, работает http://savepic.org/8518156.jpg
    так что надо понять в чем разница.



  • @out Спасибо, сейчас пробую на виртуалке



  • This post is deleted!


  • @support Не загружает файл, ошибку пишет, что файл большой. Хотя он 2мб. Залил сюда
    http://rgho.st/7hYJXXfX7
    (видео)



  • @blackhacker Да, у меня тоже стало повторяться после нескольких запусков. Сейчас разберусь.



  • @support Возможно, там код js кривой. Его там много, и он обфусцирован. Возможно, какие-то алгоритмы кода не поддерживаются движком BAS.


Log in to reply