Не запускается скрипт в режиме запуска



  • Скрипт в режиме запуска даже не инициализируется. Вот такое окошко показывает -
    Screenshot_2.png
    В логах пишет: Все данные были отработаны
    А потом крашится сам БАС.
    Это решение не помогло.
    Удалял понемногу все действия в проекте в надежде найти место где возникает ошибка, но не удалось. Скрипт остался полностью пустой, а работать в режиме запуска он всё равно отказывается.
    Вот проект - new.xml
    Буду благодарен любым подсказкам.



  • @SimpleBot said in Не запускается скрипт в режиме запуска:

    Скрипт в режиме запуска даже не инициализируется. Вот такое окошко показывает -
    Screenshot_2.png
    В логах пишет: Все данные были отработаны
    А потом крашится сам БАС.
    Это решение не помогло.
    Удалял понемногу все действия в проекте в надежде найти место где возникает ошибка, но не удалось. Скрипт остался полностью пустой, а работать в режиме запуска он всё равно отказывается.
    Вот проект - new.xml
    Буду благодарен любым подсказкам.

    В вашем скрипте нет действий, но есть кастомный модуль "ReCaptcha2"



  • @Fox да, я уже очищенный проект прикрепил, он ведь тоже глючит.
    А с этим модулем у меня другие скрипт нормально работают. Сам проект я не писал с нуля, а копировал файл другого рабочего проекта и отредактировал.



  • @SimpleBot said in Не запускается скрипт в режиме запуска:

    @Fox да, я уже очищенный проект прикрепил, он ведь тоже глючит.
    А с этим модулем у меня другие скрипт нормально работают. Сам проект я не писал с нуля, а копировал файл другого рабочего проекта и отредактировал.

    Да причём здесь это? Интерфейс у вас зависает из за бесконечного цикла без задержки, измените тип запуска

    29f25602-6889-42a9-a472-c1bc5fe81754-изображение.png

    или добавьте секундную задержку в проект



  • @Fox благодарю за подсказку. Исправил тип запуска на "Один раз" в скрипте со всеми действиями и заработало.



  • Для справки:
    Если указать количество потоков через ресурс, а ресурс с таким значением не будет создан, то происходит аналогичный вылет программы.



  • @GameBot said in Не запускается скрипт в режиме запуска:

    Для справки:
    Если указать количество потоков через ресурс, а ресурс с таким значением не будет создан, то происходит аналогичный вылет программы.

    Об этом уже был создан тикет


Log in to reply