Ошибка в скрипте



  • Попробовал накрутить просмотры ютуба с мобильных user-agent - при просмотре видео все потоки отваливаются со странной ошибкой:

    0_1503575445172_upload-cdc49f6a-3313-4e3c-836c-0a01fac4560d



  • @blackhacker А в логе тоже пусто?



  • @Fox Ага. И в этом отчете пустая строка с ошибкой) Не могу вот понять, в чем причина. Происходит сразу после загрузки страницы. Видимо, какое-то действие влияет, но отследить трудно будет, там куча всего, скрипт очень большой. Но думал, @support поможет сузить круг поиска



  • @blackhacker Ну самый проверенный вариант, это открыть проект и проштудировать в режиме записи...
    @support занятой человек. А мы попробуем помочь :D



  • Может быть ошибка синтаксиса и нужно проверять действия выполнить код, регулярки, яваскрипт. Такие ошибки не всегда срабатывают в режиме записи, но странно конечно что лог режима запуска пустой)



  • @venom777 Вряд ли есть ошибка. Давно накручиваю посещения этим скриптом)



  • @blackhacker Ну чисто теоретически ошибка либо в логике скрипта, либо в релизе BAS'a, либо ютуб поменял что то.. Тестируй эти варианты по очереди.

    1. Запусти свой же скрипт на другой машине.
    2. Запусти этот скрипт на предыдущей сборке BAS.
    3. Если ни чего не помогло, открывай в режиме записи и смотри в чём дело.


  • @Fox Я раньше не пробовал накручивать ютуб, поэтому не могу сказать, что скрипт работал раньше. Я только посещения сайтов накручивал, с сайтами все работает (кликает по рекламе). А здесь вместо клика по кнопке Play вылетает эта ошибка. Попробую посмотреть в режиме записи, что не так. Но ошибка возникает именно перед нажатием на кнопку. Там еще ютуб ставит рандомные селекторы кнопки, что осложняет задачу. Возможно, не находит тот селектор, который я указываю



  • А такое кто-нибудь видел:0_1503724696875_Снимок.JPG
    Это сразу после запуска, а при закрытии окна программа полностью вырубается. Причем в режиме записи адектватно работает. Переписал скрипт с нуля, потому что ошибку не нашел, работает нормально. Видимо что_то в ресурсах набочинил, но почему вырубается?



  • @blackhacker Это может быть связанно с нехваткой памяти для запуска потока, или чем-то подобным.
    Если хотите разобраться, попытайтесь повторить в режиме записи и прислать worker_log.txt
    В любом случае, БАС перезапускает поток после ошибки и скрипт продолжит работу, так что ошибка не критичная.



  • @denanotherday Скорее всего у вас в количестве потоков ресурс, которого не существует.


Log in to reply