Xevil + BAS Recaptcha2



  • Проблема с рекапчей 2, не понимаю, бас автоматом получает ответ?
    Действием "решить рекапчу" посылаю в хевил http://prntscr.com/n9u92r
    В логе все есть

    10.04.2019 4:46:18: POST /getTaskResult
    10.04.2019 4:46:24: POST /getTaskResult
    10.04.2019 4:46:30: POST /getTaskResult
    10.04.2019 4:46:36: POST /getTaskResult
    10.04.2019 4:46:42: POST /getTaskResult
    10.04.2019 4:46:48: POST /getTaskResult
    10.04.2019 4:46:54: POST /getTaskResult
    10.04.2019 4:47:00: POST /getTaskResult
    10.04.2019 4:47:06: POST /getTaskResult
    10.04.2019 4:47:12: POST /getTaskResult
    10.04.2019 4:47:18: POST /getTaskResult
    10.04.2019 4:47:23: ID #5: ReCaptcha2 code = 777|OK, answer = 03AOLTBLRytMgP5S0tXYFdNgUnK0ZIUUcTmYWtel4J72hJg0szXJ39MgtSkTo5XEyd8feDCcPcDaUcUisBimuudj2Umm16eBVdiSFCLvQCS2itMsfCEpaSfY_AM7NMrWY27SJoSfRo4Zaq3uDKlc4Y3llcHkZ_Cst8SYAftFKEiVShRgyNop_sGJXW5807gi2o275DNHcdh2AwRUbzya1u_ngEL_iGF7kfBotRSWhkRBtD72qjw55W3dsJJqH3iPIh7cau2-ri7orRtPwHvUT44gdQJm0vMLiKZByMHi-Atj9Z9c-Jntmwb7TRK0mkDjUtRpoq7X9xFjVV
    10.04.2019 4:47:24: POST /getTaskResult
    

    После того, как хевил отправляет ответ, в БАСЕ капча нерешенная. В хевиле стоит antigate v2, в БАСе antigate-newapi.
    Нужны какие-то дополнительные действия? Что я не так делаю?



  • @raunoww said in Xevil + BAS Recaptcha2:

    Проблема с рекапчей 2, не понимаю, бас автоматом получает ответ?
    Действием "решить рекапчу" посылаю в хевил http://prntscr.com/n9u92r
    В логе все есть

    10.04.2019 4:46:18: POST /getTaskResult
    10.04.2019 4:46:24: POST /getTaskResult
    10.04.2019 4:46:30: POST /getTaskResult
    10.04.2019 4:46:36: POST /getTaskResult
    10.04.2019 4:46:42: POST /getTaskResult
    10.04.2019 4:46:48: POST /getTaskResult
    10.04.2019 4:46:54: POST /getTaskResult
    10.04.2019 4:47:00: POST /getTaskResult
    10.04.2019 4:47:06: POST /getTaskResult
    10.04.2019 4:47:12: POST /getTaskResult
    10.04.2019 4:47:18: POST /getTaskResult
    10.04.2019 4:47:23: ID #5: ReCaptcha2 code = 777|OK, answer = 03AOLTBLRytMgP5S0tXYFdNgUnK0ZIUUcTmYWtel4J72hJg0szXJ39MgtSkTo5XEyd8feDCcPcDaUcUisBimuudj2Umm16eBVdiSFCLvQCS2itMsfCEpaSfY_AM7NMrWY27SJoSfRo4Zaq3uDKlc4Y3llcHkZ_Cst8SYAftFKEiVShRgyNop_sGJXW5807gi2o275DNHcdh2AwRUbzya1u_ngEL_iGF7kfBotRSWhkRBtD72qjw55W3dsJJqH3iPIh7cau2-ri7orRtPwHvUT44gdQJm0vMLiKZByMHi-Atj9Z9c-Jntmwb7TRK0mkDjUtRpoq7X9xFjVV
    10.04.2019 4:47:24: POST /getTaskResult
    

    После того, как хевил отправляет ответ, в БАСЕ капча нерешенная. В хевиле стоит antigate v2, в БАСе antigate-newapi.
    Нужны какие-то дополнительные действия? Что я не так делаю?

    Всё правильно. Метод newapi решает рекапчу через sitekey, после решения галочка в рекапче не ставится. Просто продолжайте работу, будто галочка стоит.



  • @fox Так мне, чтобы продолжить нужно сначала решить капчу, после этого страница должна перезагрузится и выдаст форму авторизации. Я пробовал решить капчу и перезагрузить страницу, но выдает новую капчу. Как мне поступить в этой ситуации?



  • @raunoww Там схема такая. БАС получает токен ответа, от xEvil или сервиса, это не важно и выполняет специальную функцию, которая отдает ответ серверу. После чего окошко с капчей должно исчезнуть и продолжить работу как и обычно, если бы вы решили сами.



  • @usertrue Так хевил отдает токен, БАС его получает, потому что прекращается выполнение действия "Решить рекапчу", и окошко с капчей отстается на месте.
    Если я сам с браузера это делаю, тогда, захожу на страницу - там капча - нажимаю "Я не робот" - решаю капчу - после удачного решения, страница сама перезагружается и появляется форма авторизации. Все.



  • @raunoww said in Xevil + BAS Recaptcha2:

    @usertrue Так хевил отдает токен, БАС его получает, потому что прекращается выполнение действия "Решить рекапчу", и окошко с капчей отстается на месте.
    Если я сам с браузера это делаю, тогда, захожу на страницу - там капча - нажимаю "Я не робот" - решаю капчу - после удачного решения, страница сама перезагружается и появляется форма авторизации. Все.

    всё прекрасно решает Xevil 4.0. Настройте правильно Antigate v 2 и antigate-newapi + BAS и в настройках, если указаны прокси принимает/отправляет какие надо. ( 0_1555010950830_antigate v2 api.jpg


Log in to reply