Глюк BAS?



  • Вообщем после обновления BAS появилась вот такая проблема

    alt text

    Селекторы вообще не видит...



  • @prakash попробуйте перезапустить Бас.
    0_1558428589352_2019-05-21_114924.png



  • @uraabk Перезапускал, комп перезагружал - ничего не помогло...



  • @prakash Проверьте, тут есть 0_1558429320059_test.xml



  • @uraabk Да, там есть и в "моем" сайте тоже есть, но как только авторизуешься на нем, то BAS сразу перестает видеть любые селекторы, хотя в исходном коде они 100% присутствуют и их видно. А если вручную CSS селектор прописать, то показывает, что найдено 0 (ноль) элементов, хотя он есть на странице.



  • @prakash said in Глюк BAS?:

    @uraabk Да, там есть и в "моем" сайте тоже есть, но как только авторизуешься на нем, то BAS сразу перестает видеть любые селекторы, хотя в исходном коде они 100% присутствуют и их видно. А если вручную CSS селектор прописать, то показывает, что найдено 0 (ноль) элементов, хотя он есть на странице.

    Без скрипта не разобраться



  • @uraabk said in Глюк BAS?:

    @prakash said in Глюк BAS?:

    @uraabk Да, там есть и в "моем" сайте тоже есть, но как только авторизуешься на нем, то BAS сразу перестает видеть любые селекторы, хотя в исходном коде они 100% присутствуют и их видно. А если вручную CSS селектор прописать, то показывает, что найдено 0 (ноль) элементов, хотя он есть на странице.

    Без скрипта не разобраться

    Так там и скрипта-то фактически нет - просто вход на сайт по логину и паролю (авторизация на сайте) и всё...



  • @prakash said in Глюк BAS?:

    @uraabk said in Глюк BAS?:

    @prakash said in Глюк BAS?:

    @uraabk Да, там есть и в "моем" сайте тоже есть, но как только авторизуешься на нем, то BAS сразу перестает видеть любые селекторы, хотя в исходном коде они 100% присутствуют и их видно. А если вручную CSS селектор прописать, то показывает, что найдено 0 (ноль) элементов, хотя он есть на странице.

    Без скрипта не разобраться

    Так там и скрипта-то фактически нет - просто вход на сайт по логину и паролю (авторизация на сайте) и всё...

    Что бы увидеть вашу проблемы и попытаться помочь - этого скрипта будет достаточно



  • @uraabk said in Глюк BAS?:

    @prakash said in Глюк BAS?:

    @uraabk said in Глюк BAS?:

    @prakash said in Глюк BAS?:

    @uraabk Да, там есть и в "моем" сайте тоже есть, но как только авторизуешься на нем, то BAS сразу перестает видеть любые селекторы, хотя в исходном коде они 100% присутствуют и их видно. А если вручную CSS селектор прописать, то показывает, что найдено 0 (ноль) элементов, хотя он есть на странице.

    Без скрипта не разобраться

    Так там и скрипта-то фактически нет - просто вход на сайт по логину и паролю (авторизация на сайте) и всё...

    Что бы увидеть вашу проблемы и попытаться помочь - этого скрипта будет достаточно

    Сайт светить не хочу. Да там и смотреть неначто (в скрипте). Всего три действия, ввод логина, пароля и нажатие на кнопку входа.



  • @prakash тебе говорят о том, что "Да, чувак. Мы тебя поняли, просто покажи сайт, что бы более детально его изучить и понять в чем проблема, ведь на других сайтах у людей все ок. Скорее всего, конкретно на том сайте что-то случилось."



  • @ls5stream Дык, это я и так уже понял, что дело в сайте (защита от ботов такая там). Просто хотел услышать совет, может кто с таким сталкивался и подскажет как это решить с помощью BAS.



  • @prakash попрохуй xpath файла взять прямо с сайта с браузера и поместить его в бас в то окошечко, попробуй, найдет нет



  • @ls5stream said in Глюк BAS?:

    @prakash попрохуй xpath файла взять прямо с сайта с браузера и поместить его в бас в то окошечко, попробуй, найдет нет

    Тоже ничего не находит




Log in to reply