Не работает удаление ресурса



  • Суть проста. В моем приложении если все прошло по плану, то нужно удалять ресурс и чистить его из файла через действие "Удалить текущий элемент", если соответственно нет, то можем использовать по новой. Но в реальности ничего подобного не происходит. Ресурс так и остается, никуда он не удаляется и продолжает использоваться. Накидал тестовое приложение, которое по факту кроме удаление ресурса ничего и не содержит и в нем тоже ничего не выполняется. Может я где-то туплю или это не работает в принципе?
    Если в принципе актуально, то данные хранятся в файле в папке по пути C:\Awra и BAS запущен без режима администратора
    тестовый файл прилагаю
    awra.xml



  • @checkdimon said in Не работает удаление ресурса:

    Суть проста. В моем приложении если все прошло по плану, то нужно удалять ресурс и чистить его из файла через действие "Удалить текущий элемент", если соответственно нет, то можем использовать по новой. Но в реальности ничего подобного не происходит. Ресурс так и остается, никуда он не удаляется и продолжает использоваться. Накидал тестовое приложение, которое по факту кроме удаление ресурса ничего и не содержит и в нем тоже ничего не выполняется. Может я где-то туплю или это не работает в принципе?
    Если в принципе актуально, то данные хранятся в файле в папке по пути C:\Awra и BAS запущен без режима администратора
    тестовый файл прилагаю
    awra.xml

    Вы можете просто включить опцию "запись" и в таком случае отработанные элементы ресурса удалятся сами
    16136264-e152-43fe-a159-95647b0461df-изображение.png

    а в проекте у вас ошибка в действии "Удалить Текущий Элемент", в поле "имя ресурса" вы указали несуществующий ресурс
    89fb1bf6-2a07-4012-a75f-f76e2eade460-изображение.png

    Проверьте сами awra.xml



  • @Fox мне не надо "Запись". Ибо мне не надо удалять только в определенных случаях. В смысле несуществующий? Вот же он
    45b566f5-4045-41b4-b692-ad778486d220-image.png



  • @checkdimon, имя ресурса "test", а не "test|onlyfail"



  • @checkdimon said in Не работает удаление ресурса:

    @Fox мне не надо "Запись". Ибо мне не надо удалять только в определенных случаях. В смысле несуществующий? Вот же он

    Имя вашего ресурса test, а вы указываете test|onlyfail. Опции ресурса не используются в действиях модуля "Ресурсы"
    ae5dbd4d-b5bb-431f-af74-c93f6a71b6c8-изображение.png



  • @GhostZ понял уже. спасибо


Log in to reply