BAS в режиме запуска не видит элемент



  • Странно. В режиме записи элемент всегда виден, а в режиме запуска возвращает

    Произошла ошибка : Таймаут во время выполнения script for[documentRoot, css #filepicker_dialog , frame_element , css :nth-child(3) > a]
    

    Пробовал делать выборку по CSS и по MATCH. Одно и то же. В режиме записи работает, в режиме запуска нет. В чём может быть проблема?



  • У меня таже самая проблема решения ей я так и не нашел
    Проблема как я потом в том что BAS в режиме Запуска не может получить содержимое iframe html



  • Причём эта проблема появилась после последнего обновления. Стояла старая версия, где то полугодичной давности, в ней работало. А тут решил обновиться и всё сломалось. Это явно косяк БАСа. Как бы намекнуть авторам, чтоб обратили внимание на этот косяк и поправили поскорее? Если нужно могу сделать скрины.





  • Вы , у кого ошибки , случаем не используете "пропуск кадров" в большом значении...???
    после последних Обновлений BAS , уже при "пропуск кадров"=10 бывает не находит Элементы , хотя они есть. в "Записи" работает в "Запуске" нет



  • @VSERODcom said in BAS в режиме запуска не видит элемент:

    Вы , у кого ошибки , случаем не используете "пропуск кадров" в большом значении...???
    после последних Обновлений BAS , уже при "пропуск кадров"=10 бывает не находит Элементы , хотя они есть. в "Записи" работает в "Запуске" нет

    Спасибо тебе, добрый человек!!! А ведь действительно, помню мой скрипт сильно тупил в браузере в многопотоке, и я поставил пропуск 50. И в старых версиях работало. А после обновления БАСа перестало. Сейчас вот вернул пропуск в 1 и о чудо! Работает! Элементы видит! СПАСИБО!!!



  • @Mifody128 Если мне не изменяет память, Бас по умолчания использует 75. Поправьте если не прав, но где то читал.



  • Честно, не помню, сколько там стояло по умолчанию. Помню только, что игрался этим значением из за тупежа браузера в многопотоке. Тяжело компу было. Сейчас поставил в 0, но значение изменилось само на 1. И всё работает, элементы видит. Сейчас пропуск не актуален для меня, так как алгоритм уже совсем другой и даже в многопотоке больше 1 браузера не запускается.



  • А вот для меня актуален пропуск кадров.... проблема такая же элемент не находится при пропуске больше 10. Ни кто решения не нашел?


Log in to reply