При выполнении действия все работает, при запуске нет



  • Здравствуйте! При написании скрипта для постинга ВК, возникло дикое желание прекратить работать с этим продуктом. При загрузке фото и вводе текста, должна нажиматься кнопка "опубликовать". При проигрывании скрипта с помощью "выполнение дествия" все работает нормально, но стоит только запустить скрипт, действия нажатия на фото, а затем и кнопка "опубликовать" просто пропускаются и скрипт работает дальше. В чем может быть проблема и как это устранить?
    P.s. пробовал различные способы исправить самому: менял действия, ставил ждать загрузки элемента/спать, меня сами элементы - но ничего не помогает. Также попробовал воспользоваться поиском, но , увы, все тщетно.



  • Посмотри в настройках проекта не установлено ли у тебя значение
    Пропуск кадров отличное от 1
    если там не 1
    поставь 1
    и сохрани настройки
    а потом пробуй запустить



  • Нажатие как делаете через селектор или по координатам? Если по координатам то может быть из за этого



  • @Ernecto said in При выполнении действия все работает, при запуске нет:

    Здравствуйте! При написании скрипта для постинга ВК, возникло дикое желание прекратить работать с этим продуктом.

    Кривой кирпич подсунули

    alt text

    При загрузке фото и вводе текста, должна нажиматься кнопка "опубликовать". При проигрывании скрипта с помощью "выполнение дествия" все работает нормально, но стоит только запустить скрипт, действия нажатия на фото, а затем и кнопка "опубликовать" просто пропускаются и скрипт работает дальше. В чем может быть проблема и как это устранить?
    P.s. пробовал различные способы исправить самому: менял действия, ставил ждать загрузки элемента/спать, меня сами элементы - но ничего не помогает. Также попробовал воспользоваться поиском, но , увы, все тщетно.

    100ce1f2-4e57-4c37-82ae-3454cd4dd4b2-изображение.png


    alt text


    93589a53-710f-4c4a-8f5a-f4a8e0ac4812-изображение.png



  • @kuzkuz через селекторы естественно. Думаю, может и за циклов проблема?



  • @gomeapat хорошо, спасибо, попробую)



  • @Fox спасибо, но если вы думаете, что мой скрипт чем то отличается, спешу вас огорчить, - тоже самое.



  • @Ernecto said in При выполнении действия все работает, при запуске нет:

    спешу вас огорчить

    😅 Ну все @fox ушел бухать с горя ))

    @Ernecto said in При выполнении действия все работает, при запуске нет:

    @Fox спасибо, но если вы думаете, что мой скрипт чем то отличается, спешу вас огорчить, - тоже самое.

    Дак приложите свой проект



  • @UserTrue беру слова обратно, изначально бегло глянул. У меня не было действия "ждать появления элемента" - это относительно загрузки картинки. Но было дествие ждать появление кнопки "опубликовать". Сейчас протестил, вроде работает. Попробую в основной скрипт так сделать.


Log in to reply