шаблон не выполняется в цикле(только один проход)



  • сделал простой шаблон который использует ресурс с файлом прокси и чекает на сайте и пишет лог. но всегда шаблон проходит один раз. цикла не получается чтобы проверить весь список айпи(строк из ресурса). первый скрипт. в чем может быть проблема. пробовал и у в ресурсе увеличивать значения и потоки в шаблоне и успешные и не успешные. проходит от инициализации до конца шаблона и стоит так.



  • @oleg4ever запустите в режиме запуска



  • я ведь правильно понимаю что шаблон должен закончится и опять пройти через инициализацию то тогда прокси должен переключится.

    то есть я не должен делать метку( как бы goto start).

    если цикл шаблона не закончился, но прыжок на метку вверх на start(кубик под инициализацией выполнен), то кубик прокси отработает идентично если бы шаблон кончился. просто пока еще не понял вообще инициализация выполняется много раз или один раз в шаблоне.

    думаю твой совет верный. ролики на ютубе когда смотрел то там айпи так и чекали не в тестере. с чем это связано?



  • в режиме запуска работает по другому. почему так?

    еще вопрос. в проекте 10 потоков 1 успешный 1 не успешный. в ресурсе тоже по единичкам(1). а в логе повторы есть. почему так? (повторы идут на том же потоке) в настройках прокси "повторы" отключены



  • @oleg4ever было такое реализовал так:
    1 получить кол-во элементов
    2 цикл for настраиваем от 1 до переменная с кол-во элементов
    3 в for оборачиваем нужные для цикла действия.
    А проблема возмоно в том, что цикл видит только один элемент, его и проходит. Поэтому если если и этот вариант не пройдет ищи подходящий селектор.



  • @oleg4ever said in в логе повторы есть. почему так? (повторы идут на том же потоке) в настройках прокси "повторы" отключены

    Если я правильно понял, то при использовании ресурса нужно убирать галку в "повторное использование". Должно получиться так: {{AKKAUNT|notreuse}}



  • @DrPrime напишите контакты для связи, хочу скрипт заказать.



  • @denanotherday said in шаблон не выполняется в цикле(только один проход):

    А проблема возмоно в том, что цикл видит только один элемент, его и проходит.

    в режиме запуска видит весь ресурс



  • @oleg4ever said in шаблон не выполняется в цикле(только один проход):

    в режиме запуска работает по другому. почему так?

    сам же и отвечу. в режиме отладки работает только один поток. Многопоток запускайте в режиме запуска.
    DrPrime все верно сказал. Thx.


Log in to reply