Пропадает интерфейс во время записи и запуска



  • Добрый день. Время от времени пропадает интерфейс в записи или в запуске. Однако БАС считает что все хорошо и скрипт выполняется дальше. Всё что можно сделать это вручную его остановить. Как это можно решить?12133.png



  • @znuker Скорей всего ресурсов ПК не хватает



  • @znuker said in Пропадает интерфейс во время записи и запуска:

    Добрый день. Время от времени пропадает интерфейс в записи или в запуске. Однако БАС считает что все хорошо и скрипт выполняется дальше. Всё что можно сделать это вручную его остановить. Как это можно решить?

    В режиме запуска какой интерфейс пропадает? Для режима "записи" есть наблюдения, при каких обстоятельствах это происходит?



  • @Fox В запуске происходит также как и на скрине. Обычно рандомно всё, но заметил что на долгой дистанции чаще это происходит



  • @znuker said in Пропадает интерфейс во время записи и запуска:

    @Fox Обычно рандогмно всё, но заметил что на долгой дистанции чаще это происходит

    у вас по долгу скрипт работает в режиме "записи"? И вы так и не ответили, какой интерфейс пропадает в режиме "запуска"?



  • @Fox Да подолгу. Пропадает как на скрине в запуске



  • @znuker said in Пропадает интерфейс во время записи и запуска:

    @Fox Да подолгу. Пропадает как на скрине в запуске

    У меня в запуске скрипты выглядят точно так же, уточните какой интерфейс пропадает?

    4b8c9821-f75a-4705-9f64-201a1323c377-изображение.png



  • У друга кстати тоже пропадает иногда.В общем написал я скрипт у меня все норм запускаю в 20 потоков проблем никаких(если не считать ошибок которые выскакивают из за нехватки ресурсов) у друга тот же скрипт работает в 50 потоков загрузка около 80% так вот иногда у него бывает что если запустить а через пару минут перезапустить скрипт то браузеры(каждый поток запускает браузер) не появляются,соответственно скрипт не работает.Длится такая ошибка по разному от 10 до 20 минут при этом не помогает не перезапуск бас не перезагрузка компа.



  • @xtra said in Пропадает интерфейс во время записи и запуска:

    У друга кстати тоже пропадает иногда.В общем написал я скрипт у меня все норм запускаю в 20 потоков проблем никаких(если не считать ошибок которые выскакивают из за нехватки ресурсов) у друга тот же скрипт работает в 50 потоков загрузка около 80% так вот иногда у него бывает что если запустить а через пару минут перезапустить скрипт то браузеры(каждый поток запускает браузер) не появляются,соответственно скрипт не работает.Длится такая ошибка по разному от 10 до 20 минут при этом не помогает не перезапуск бас не перезагрузка компа.

    один раз была проблема краша интерфейса из за конкретной ситуации на конкретном сайте, это потом поправили.
    Может всё же есть какие то закономерности в вашем случае?



  • ну тут сказать сложно.Такое было 2-3 раза за месяц использования.Единственное общее между этими случаями это потоков больше 50(опять же повторю каждый поток запускает браузер) и перезапуск скрипта через 5 минут после запуска максимум.По сути не такая уж и большая проблема и не доставляет много проблем,просто решил отписаться авось знающие люди что посоветуют



  • @xtra said in Пропадает интерфейс во время записи и запуска:

    ну тут сказать сложно.Такое было 2-3 раза за месяц использования.Единственное общее между этими случаями это потоков больше 50(опять же повторю каждый поток запускает браузер) и перезапуск скрипта через 5 минут после запуска максимум.По сути не такая уж и большая проблема и не доставляет много проблем,просто решил отписаться авось знающие люди что посоветуют

    Не уверен, что я подхожу под описания "знающего", но я бы попросил больше информации при повторении ситуации. Например если в каком то скрипте такое происходит, проверить его скомпилированную версию



  • @Fox 12133.png Выглядит так а пропадает всё как и в записи.



  • @Fox В увеличением скрипта увеличилась и частота появления этого явления. P.s иногда появляется эта ошибка 1111.png



  • @znuker said in Пропадает интерфейс во время записи и запуска:

    @Fox Выглядит так а пропадает всё как и в записи.

    Интерфейс BAS в режиме "запуска" так и выглядит, я всё равно не понимаю, что у вас пропадает

    @znuker said in Пропадает интерфейс во время записи и запуска:

    @Fox В увеличением скрипта увеличилась и частота появления этого явления. P.s иногда появляется эта ошибка

    Какая? Та, что в логе, или какая то в интерфейсе?



  • @Fox Все браузеры пропадают и не работают соответственно



  • Какая? Та, что в логе, или какая то в интерфейсе?
    Ошибка эта редко она сопровождает закрытие браузеров.



  • ошибка из за эмитации бездействия,можно ее заменить на спать и ее не будет.Возможно не хватает ресурсов пк.


Log in to reply
 

  • 4
  • 7
  • 2
  • 13
  • 2
  • 5
  • 2
  • 14